   






<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="http://elkodaily.com/content/tncms/live/" />
<meta name="keywords" content=", wire" />
<meta name="news_keywords" content=", wire" />
<meta name="description" content="2. The high-profile cuts Speaking of Mathieu, he's one of several established stars to hit the open market with plenty of gas left in the tank. Veterans who are available" />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1, user-scalable=0, shrink-to-fit=no" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="apple-itunes-app" content="app-id=441519593" />
<meta name="google-play-app" content="app-id=com.elkodaily.news" />
<meta name="google-site-verification" content="ajIqbfHKqqHmTWWTpWMqbhC52W27D5M1xTL44a5ZXCU" />
<meta name="msvalidate.01" content="106560791A6200A80BCECBE5E23A2EA2" />
<meta name="y_key" content="PRah6gnV34E7FNluCkd0BOm4bVhTShpfdHje8j8ERnO4zik1QdfubwS2da8_bXeYow--" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://elkodaily.com/sports/football/the-high-profile-cuts-speaking-of-mathieu-he-s-one/image_ce623af1-32eb-5914-89bd-4a2f98ec8534.html" />
<meta property="og:image" content="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/assets/v3/editorial/c/e6/ce623af1-32eb-5914-89bd-4a2f98ec8534/5aaaa8f4281f7.image.jpg?crop=1024%2C576%2C0%2C57&amp;resize=1024%2C576&amp;order=crop%2Cresize" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="576" />
<meta property="og:title" content="2. The high-profile cuts

Speaking of Mathieu, he's one of several established stars to hit the open market with plenty of gas left in the tank. Veterans who are available into the second and third waves of free agency, never mind the ones cut as the proceedings are getting underway, generally have non-football concerns &mdash; whether they're related to contract, durability or off-field questions.

But Mathieu led the NFL in defensive snaps last season, just one removed from his second major knee injury, and has already proven he's one of the game's more perseverant players. He's also one of its most versatile and exciting, and we can't think of too many defenses that shouldn't want to find a place for him.

While &quot;Honey Badger&quot; comes with a durability buyer beware tag, Ndamukong Suh's issues are very different. He's missed just two games in his first eight seasons, including a Defensive Rookie of the Year and five All-Pro nominations. He can still be a dominant player &mdash; when he wants to.

Indeed, the factor clubs considering Suh must weigh &mdash; and, like Mathieu, there aren't many defenses that couldn't use Suh's services &mdash; is his motor and motivation. One of the NFL's best businessmen &mdash; Suh has cashed $124 million already in his NFL career &mdash; made no bones about the fact in a conversation with ESPN on Wednesday that his next team will be the one willing to offer him the most financially. Forget fit. Forget finally winning in the postseason, which Suh has yet to do in three games over eight seasons.

Perhaps neither of these players are for everyone, then, but they're both special talents who still will command big contracts, which is a bit unusual at this juncture of free agency." />
<meta property="og:description" content="2. The high-profile cuts Speaking of Mathieu, he's one of several established stars to hit the open market with plenty of gas left in the tank. Veterans who are available" />
<meta property="og:site_name" content="Elko Daily Free Press" />
<meta property="og:section" content="Football" />
<meta property="fb:app_id" content="136428783038289" />
<meta property="article:publisher" content="https://www.facebook.com/elkodaily/" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@elkodaily" />
<meta property="fb:pages" content="127993293932724" />
<meta name="parsely-title" content="2. The high-profile cuts

Speaking of Mathieu, he's one of several established stars to hit the open market with plenty of gas left in the tank. Veterans who are available into the second and third waves of free agency, never mind the ones cut as the proceedings are getting underway, generally have non-football concerns &mdash; whether they're related to contract, durability or off-field questions.

But Mathieu led the NFL in defensive snaps last season, just one removed from his second major knee injury, and has already proven he's one of the game's more perseverant players. He's also one of its most versatile and exciting, and we can't think of too many defenses that shouldn't want to find a place for him.

While &quot;Honey Badger&quot; comes with a durability buyer beware tag, Ndamukong Suh's issues are very different. He's missed just two games in his first eight seasons, including a Defensive Rookie of the Year and five All-Pro nominations. He can still be a dominant player &mdash; when he wants to.

Indeed, the factor clubs considering Suh must weigh &mdash; and, like Mathieu, there aren't many defenses that couldn't use Suh's services &mdash; is his motor and motivation. One of the NFL's best businessmen &mdash; Suh has cashed $124 million already in his NFL career &mdash; made no bones about the fact in a conversation with ESPN on Wednesday that his next team will be the one willing to offer him the most financially. Forget fit. Forget finally winning in the postseason, which Suh has yet to do in three games over eight seasons.

Perhaps neither of these players are for everyone, then, but they're both special talents who still will command big contracts, which is a bit unusual at this juncture of free agency." />
<meta name="parsely-link" content="http://www.profootballweekly.com/lists/2018/03/15/c2b9525b32694cdaa7c2a19dc670fe90/index.xml" />
<meta name="parsely-type" content="post" />
<meta name="parsely-pub-date" content="2018-03-15T15:22:00-0700" />
<meta name="parsely-post-id" content="ce623af1-32eb-5914-89bd-4a2f98ec8534" />
<meta name="parsely-image-url" content="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/assets/v3/editorial/c/e6/ce623af1-32eb-5914-89bd-4a2f98ec8534/5aaaa8f4281f7.image.jpg?crop=1024%2C576%2C0%2C57&amp;resize=1024%2C576&amp;order=crop%2Cresize" />
<meta name="parsely-section" content="Football" />
<meta name="parsely-tags" content=", wire" />
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.2be7ddf414805ae1a81e8d6a3f9bbd90.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/font-awesome.min.aa9489b4ca0b873d5d02e199b14b98e9.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.71b7d02c0408edaee8de52e95fc92ad5.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.b48eb4a61f06e598745b7911a9b44c21.css"/>
<!--[if lt IE 9]><link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/ie.528f4890d200be3d74c01fb9f9f702e7.css"/><![endif]-->
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/live/libraries/flex/components/lee_flex/resources/styles/lee-ds.min.css?_dc=1521101043"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/weather-icons.min.c407cda878049fe24659eed3340b38bc.css"/>
<link rel="stylesheet" href="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.59dd3789bb083dfa248fbbfcd0806958.css"/>
<style>/*<![CDATA[*/ .follow-links-1466116 li { margin-right: 1px; padding: 0; } .follow-links-1466116 li a, .follow-links-1466116 li a:focus, .follow-links-1466116 li a:active { ; color: #fff!important; font-size: 18px; margin-right: 10px; opacity: .8; padding:0; box-shadow: none; } .follow-links-1466116 li a:hover { text-decoration: none; opacity: 1; } .follow-links-1466116 li a.fb:hover { color: #3A59A5; } .follow-links-1466116 li a.tw:hover { color: #46C8F9; } .follow-links-1466116 li a.yt:hover { color: #CE2B29; } #user-controls-1466051 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1466051 .tn-user-screenname, #user-controls-1466051 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1466051 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1466051 .dropdown-signup { font-size: 12px; } #user-controls-1466051 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1466051 .large-user-avatar { margin-right: 10px; } #user-controls-1466051 .large-user-controls { font-size: 12px; } #user-controls-1466051 .logout-btn { cursor: pointer; } #user-controls-1466051 .login-btn { background-color: #555; border-color: #555; } #user-controls-1466051 .login-btn:hover { text-decoration: underline; } #block-1466083 .search-spinner { position: absolute; } #block-1466083 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-1466083-dropdown.site-search-full .dropdown-menu .form-control { border: none; box-shadow: none; } #site-search-1466083-dropdown.site-search-full .dropdown-menu .btn { border-radius: 2px; } #user-controls-1466084 .user-controls .dropdown-menu > li > a { padding: 5px 20px; } #user-controls-1466084 .tn-user-screenname, #user-controls-1466084 .large-user-controls .user-welcome { padding: 0 5px; max-width: 75px; text-overflow: ellipsis; white-space: nowrap; overflow: hidden; } #user-controls-1466084 .large-user-controls .user-welcome { padding:0; max-width: 100%; font-weight: bold; } #user-controls-1466084 .dropdown-signup { font-size: 12px; } #user-controls-1466084 .large-user-controls .tn-user-screenname { padding: 0; } #user-controls-1466084 .large-user-avatar { margin-right: 10px; } #user-controls-1466084 .large-user-controls { font-size: 12px; } #user-controls-1466084 .logout-btn { cursor: pointer; } #user-controls-1466084 .login-btn { color: #fff!important; } #weather-1466085 .list-unstyled { margin: 0; } #weather-1466085 span { display: block; } #weather-1466085 .forecast-link a { padding: 8px; margin-top: -10px; } #weather-1466085 .icon { position: relative; font-size: 24px; margin-right: 10px; } #weather-1466085 .temp { font-size: 18px; font-weight: bold; } #weather-1466085 .cond { opacity: 0.7; } #weather-1466085 .current-conditions { float: left; height: 24px; } #weather-1466085 .dropdown-toggle { color: #fff; display: block; } #weather-1466085 .weather-alert-btn { right: 0; position: absolute; margin-right: 0px; margin-top: 3px; padding: 0 2px; } #weather-1466085 .city-title { padding-top: 5px; } #weather-1466085 .weather-expanded { padding: 0 15px; width: 300px; font-weight: normal; } #weather-1466085 .weather-expanded h5 { border-top: 1px solid rgba(0,0,0,.05); padding-top: 10px; } #weather-1466085 .weather-expanded small { opacity: 0.5; } #weather-1466085 .zip-update-form { width: 140px; margin-top: -54px; background-color: #eee; padding: 5px; position: absolute; display: none; right: 0; } #weather-1466085 .zip-update { width: 75px; } #weather-1466085 .zip-update-link { color: #999; font-size: 18px; text-decoration: none; } #weather-1466085 .zip-update-link:hover { color: #777; } #block-1466086 .breaking-title { background-color: #C9302C; } #block-1466086 .breaking, #block-1466086 .breaking .container { background-color: #D9534F; } #block-1516146 .card.summary { border: 0; padding: 0; margin: 0; } #block-1516146 .card-panel { background-color:#fff; border-color: rgba(0,0,0,.08); } #site-logo-1466056 { color: #666; } .follow-links-1466117 li { margin-right: 1px; padding: 0; } .follow-links-1466117 li a, .follow-links-1466117 li a:focus, .follow-links-1466117 li a:active { ; color: #4a3379!important; font-size: 18px; margin-right: 10px; opacity: .8; padding:0; box-shadow: none; } .follow-links-1466117 li a:hover { text-decoration: none; opacity: 1; } .follow-links-1466117 li a.fb:hover { color: #3A59A5; } .follow-links-1466117 li a.tw:hover { color: #46C8F9; } .follow-links-1466117 li a.yt:hover { color: #CE2B29; } /*]]>*/</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"page":{"app":"editorial","skin":"flex-editorial","theme":"flex","http_status":200},"client":{"is_bot":"no","noscript":false},"system":{"render_time":319}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=UaWpb3d_PDCaIVzoLRLRYA&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="//tags.crwdcntrl.net/c/6894/cc.js?ns=_cc6894" id="LOTCC_6894"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc6894.add('tp', 'TNNW');
		_cc6894.add('act', ' User Login');
		_cc6894.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
	}
	_cc6894.bcp();
</script>

<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms/subscription.js"></script>
<script>/*<![CDATA[*/ TNCMS.Subscription.setServiceIds("5409,5591,4698,5812,4699,4700"); TNCMS.Subscription.trackAam(); /*]]>*/</script>
<script>/*<![CDATA[*/ window.LEE_DS = true; /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.b354cc9d56a1da6b0c77604d1b153850.js"></script>
<script>/*<![CDATA[*/ TNCMS.User.restorePersistentSession(); /*]]>*/</script>
<!--[if lt IE 9]><script src="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.legacy.min.3c9137d88a00b1ae0b41ff6a70571615.js"></script><![endif]-->
<script src="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.0d8719807a3fe7b72ef1938c41d415c2.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.aecb24225decfdb548cb8abcad610e26.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.5a7913d68b6c90e1d5b904abf321ff8c.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.df2ec67117eb052ffe5fe81af182faa3.js"></script>
<!--[if lt IE 9]><script src="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/html5shiv.5a98a86b5cb48c1506f338463259ce41.js"></script><![endif]-->
<!--[if lt IE 9]><script src="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/respond.min.579a7a602077ed841332e866504896aa.js"></script><![endif]-->
<script>/*<![CDATA[*/ var __tnt = __tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.slots = __tnt.ads.dfp.slots || {};
    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["","wire"];
    __tnt.ads.dfp.targeting.page=["asset","image","app-editorial"];
    if( typeof window.I10C != 'undefined' && typeof window.I10C.Morph != 'undefined' ){
        __tnt.ads.dfp.targeting.page.push('recover');
    }
    
    __tnt.docWidth = window.innerWidth;
    if( __tnt.docWidth > 1899 ){ 
        __tnt.docWidthBreakPoint = 'xl_screen';
    } else if ( __tnt.docWidth > 1619 ){
        __tnt.docWidthBreakPoint = 'lg_screen';
    } else if ( __tnt.docWidth > 991 ){
        __tnt.docWidthBreakPoint = 'md_screen';
    } else if ( __tnt.docWidth > 767 ){
        __tnt.docWidthBreakPoint = 'sm_screen';
    } else {
        __tnt.docWidthBreakPoint = 'xs_screen';
    }
    __tnt.ads.dfp.targeting.page.push(__tnt.docWidthBreakPoint);

    window.googletag = window.googletag || {};
    window.googletag.cmd = window.googletag.cmd || [];

    (function() {
        var gads = document.createElement('script');
        gads.async = true;
        gads.type = 'text/javascript';
        var useSSL = 'https:' == document.location.protocol;
        gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
    })(); /*]]>*/</script>
<script>/*<![CDATA[*/ window.APS_dfp_ads = [];
    
    !function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
    
    apstag.init({
        pubID: '3266',
        adServer: 'googletag'
    }); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.0fcadf320e46b9f4bd138a51d0805381.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.advertisements.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>

            
            <title>2. The high-profile cuts

Speaking of Mathieu, he's one of several established stars to hit the open market with plenty of gas left in the tank. Veterans who are available into the second and third waves of free agency, never mind the ones cut as the proceedings are getting underway, generally have non-football concerns — whether they're related to contract, durability or off-field questions.

But Mathieu led the NFL in defensive snaps last season, just one removed from his second major knee injury, and has already proven he's one of the game's more perseverant players. He's also one of its most versatile and exciting, and we can't think of too many defenses that shouldn't want to find a place for him.

While &quot;Honey Badger&quot; comes with a durability buyer beware tag, Ndamukong Suh's issues are very different. He's missed just two games in his first eight seasons, including a Defensive Rookie of the Year and five All-Pro nominations. He can still be a dominant player — when he wants to.

Indeed, the factor clubs considering Suh must weigh — and, like Mathieu, there aren't many defenses that couldn't use Suh's services — is his motor and motivation. One of the NFL's best businessmen — Suh has cashed $124 million already in his NFL career — made no bones about the fact in a conversation with ESPN on Wednesday that his next team will be the one willing to offer him the most financially. Forget fit. Forget finally winning in the postseason, which Suh has yet to do in three games over eight seasons.

Perhaps neither of these players are for everyone, then, but they're both special talents who still will command big contracts, which is a bit unusual at this juncture of free agency. | Football | elkodaily.com</title>
            
    
    <style>body { background-color: #f7f7f7; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #4a3379; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #f7f7f7; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #4a3379; } .fixed-nav #main-navigation { background-color: #4a3379 !important; } #site-top-nav-container, #site-top-nav { background-color: #ffffff; } #site-footer { background-color: #f7f7f7; color: #888888; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #fff; } .navbar-toggle .icon-bar { background-color: #fff !important; } .navbar-toggle .sr-only-show { color: #fff !important; } #site-top-nav .list-inline>li>a { color: #4175aa; } .asset .asset-body p, .asset #asset-content p { color: #444; }#site-header-container {background-color: #4a3379;}/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* remove full span bgs */ #site-footer-container { background-color: transparent !important; background-image: none !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #fff; } }#site-copyright a, #site-footer a { color: #333333; }</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="http://elkodaily.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/custom/image/378fdd70-a9b9-11e5-a091-fb20aff5c138.png?_dc=1450904867" />
    <link rel="alternate" type="application/rss+xml" title="2. The high-profile cuts

Speaking of Mathieu, he's one of several established stars to hit the open market with plenty of gas left in the tank. Veterans who are available into the second and third waves of free agency, never mind the ones cut as the proceedings are getting underway, generally have non-football concerns — whether they're related to contract, durability or off-field questions.

But Mathieu led the NFL in defensive snaps last season, just one removed from his second major knee injury, and has already proven he's one of the game's more perseverant players. He's also one of its most versatile and exciting, and we can't think of too many defenses that shouldn't want to find a place for him.

While &quot;Honey Badger&quot; comes with a durability buyer beware tag, Ndamukong Suh's issues are very different. He's missed just two games in his first eight seasons, including a Defensive Rookie of the Year and five All-Pro nominations. He can still be a dominant player — when he wants to.

Indeed, the factor clubs considering Suh must weigh — and, like Mathieu, there aren't many defenses that couldn't use Suh's services — is his motor and motivation. One of the NFL's best businessmen — Suh has cashed $124 million already in his NFL career — made no bones about the fact in a conversation with ESPN on Wednesday that his next team will be the one willing to offer him the most financially. Forget fit. Forget finally winning in the postseason, which Suh has yet to do in three games over eight seasons.

Perhaps neither of these players are for everyone, then, but they're both special talents who still will command big contracts, which is a bit unusual at this juncture of free agency. | Football | elkodaily.com" href="http://elkodaily.com/search/?f=rss&amp;t=article&amp;c=sports/football&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="http://www.profootballweekly.com/lists/2018/03/15/c2b9525b32694cdaa7c2a19dc670fe90/index.xml" />
            
    
            
        </head>
        <body class="fixed-scroll-nav  blox-asset app-editorial uuid-ce623af1-32eb-5914-89bd-4a2f98ec8534  section-sports section-football type-image ">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('elkodaily.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&tncms.page.app=editorial&tncms.page.skin=flex-editorial&tncms.page.theme=flex&tncms.page.http_status=200&tncms.client.is_bot=no&tncms.client.noscript=yes&tncms.system.render_time=319" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
            <div id="parsely-root" style="display: none">
                <span id="parsely-cfg" data-parsely-site="elkodaily.com"></span>
            </div>
            <script>
                (function(s, p, d) {
                var h=d.location.protocol, i=p+"-"+s,
                e=d.getElementById(i), r=d.getElementById(p+"-root"),
                u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net"
                :"static."+p+".com";
                if (e) return;
                e = d.createElement(s); e.id = i; e.async = true;
                e.src = h+"//"+u+"/p.js"; r.appendChild(e);
                })("script", "parsely", document);
            </script>
        <div id="fb-root"></div>
        
        
        
            <!-- Google Tag Manager -->
            <script>
                var dataLayer = window.dataLayer || [];
                dataLayer.push({"ga_ua":"UA-54716522-2","chartbeat":"true","taxonomy_1":"sports","taxonomy_2":"football","taxonomy_3":null,"taxonomy_4":null,"taxonomy_5":null,"blox_platform":"desktop","blox_page_type":"asset","blox_domain":"elkodaily.com","blox_skin":"flex-editorial","blox_application":"editorial","groups":{"content":"1","advertising":"2","utility":"3"},"content_group":"1","content_group_id":"sports","blox_sections":"sports,football","weather_temp":35,"weather_conditions":"Overcast","asset_source":"associated press","blox_asset_type":"image","asset_section":null,"asset_id":"ce623af1-32eb-5914-89bd-4a2f98ec8534","asset_headline":"2. The high-profile cuts\n\nSpeaking of Mathieu, he's one of several established stars to hit the open market with plenty of gas left in the tank. Veterans who are available into the second and third waves of free agency, never mind the ones cut as the proceedings are getting underway, generally have non-football concerns \u2014 whether they're related to contract, durability or off-field questions.\n\nBut Mathieu led the NFL in defensive snaps last season, just one removed from his second major knee injury, and has already proven he's one of the game's more perseverant players. He's also one of its most versatile and exciting, and we can't think of too many defenses that shouldn't want to find a place for him.\n\nWhile \"Honey Badger\" comes with a durability buyer beware tag, Ndamukong Suh's issues are very different. He's missed just two games in his first eight seasons, including a Defensive Rookie of the Year and five All-Pro nominations. He can still be a dominant player \u2014 when he wants to.\n\nIndeed, the factor clubs considering Suh must weigh \u2014 and, like Mathieu, there aren't many defenses that couldn't use Suh's services \u2014 is his motor and motivation. One of the NFL's best businessmen \u2014 Suh has cashed $124 million already in his NFL career \u2014 made no bones about the fact in a conversation with ESPN on Wednesday that his next team will be the one willing to offer him the most financially. Forget fit. Forget finally winning in the postseason, which Suh has yet to do in three games over eight seasons.\n\nPerhaps neither of these players are for everyone, then, but they're both special talents who still will command big contracts, which is a bit unusual at this juncture of free agency.","asset_byline":"","asset_pub_date":"03\/15\/2018","asset_pub_time":"3:22 pm","asset_canonical":"http:\/\/www.profootballweekly.com\/lists\/2018\/03\/15\/c2b9525b32694cdaa7c2a19dc670fe90\/index.xml","asset_tag_1":"wire","asset_flag_1":"ap","syndication_domain":"profootballweekly.com","syndication_headline":"2. The high-profile cuts\n\nSpeaking of Mathieu, he's one of several established stars to hit the open market with plenty of gas left in the tank. Veterans who are available into the second and third waves of free agency, never mind the ones cut as the proceedings are getting underway, generally have non-football concerns \u2014 whether they're related to contract, durability or off-field questions.\n\nBut Mathieu led the NFL in defensive snaps last season, just one removed from his second major knee injury, and has already proven he's one of the game's more perseverant players. He's also one of its most versatile and exciting, and we can't think of too many defenses that shouldn't want to find a place for him.\n\nWhile \"Honey Badger\" comes with a durability buyer beware tag, Ndamukong Suh's issues are very different. He's missed just two games in his first eight seasons, including a Defensive Rookie of the Year and five All-Pro nominations. He can still be a dominant player \u2014 when he wants to.\n\nIndeed, the factor clubs considering Suh must weigh \u2014 and, like Mathieu, there aren't many defenses that couldn't use Suh's services \u2014 is his motor and motivation. One of the NFL's best businessmen \u2014 Suh has cashed $124 million already in his NFL career \u2014 made no bones about the fact in a conversation with ESPN on Wednesday that his next team will be the one willing to offer him the most financially. Forget fit. Forget finally winning in the postseason, which Suh has yet to do in three games over eight seasons.\n\nPerhaps neither of these players are for everyone, then, but they're both special talents who still will command big contracts, which is a bit unusual at this juncture of free agency."});
                dataLayer.push(
                    {'user_id': __tnt.user.screenName},
                    {'user_state': __tnt.user.loggedIn ? 'logged in' : 'anonymous'},
                    {'utm_label': __tnt.urlHash('utm_label')}
                );
            </script>
            <noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TDWDC2" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
            <script>
                (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
                new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
                j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
                '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
                })(window,document,'script','dataLayer','GTM-TDWDC2');
            </script>
        
        <script>    
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'gaTriggerEvent',
                        'gaEventCategory': obj.category,
                        'gaEventAction': obj.action,
                        'gaEventLabel': obj.label,
                        'gaEventValue': obj.value
                    });
                }
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'socialEvent',
                        'socialNetwork': obj.network,
                        'socialAction': obj.socialAction,
                        'socialTarget': obj.url
                    });
                }
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'VirtualPageview',
                        'virtualPageURL': sURL,
                        'virtualPageTitle': obj.title
                    });
                }
        </script>
        <!-- End Google Tag Manager -->
        
<script>
$(function(){
var bloxServiceIDs = [];
var bloxUserServiceIds = [];
var dataLayer = window.dataLayer || [];


bloxServiceIDs.push(5409);

bloxServiceIDs.push(5591);

bloxServiceIDs.push(4698);

bloxServiceIDs.push(5812);

bloxServiceIDs.push(4699);

bloxServiceIDs.push(4700);


if (__tnt.user.services){
    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
}            

// GTM tncms.subscription.paid_access_service_ids
if(bloxServiceIDs){
    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
}
                
// GTM tncms.subscrption.user_service_ids
if(bloxUserServiceIDs){
    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
}

});
</script>


        <div class="tnt-ads-container text-center "><div style="min-height:1px; min-width:2px;" class="tnt-ads dfp-ad" data-dfp-adunit="/8438/elkodaily.com/sports/football" data-dfp-custom-pos="fixed-impact-top, atf" id="fixed-impact-top" data-dfp-size="[2,1]"></div></div>
    
        <div id="site-container">
            <div id="asset-edit-container-ce623af1-32eb-5914-89bd-4a2f98ec8534" class="asset-owner-content asset-edit-container progress hidden-print">
            <div class="progress-bar progress-bar-primary progress-bar-striped">
                <div class="asset-edit-icon pull-left hidden-sm hidden-xs"><i class="fa fa-certificate"></i></div>
                <div class="asset-edit-message pull-left">You are the owner of this image.</div>
                <div class="asset-edit-btns pull-right">
                    <a class="btn btn-primary" href="https://elkodaily.com/users/admin/contribute/image/?assetid=ce623af1-32eb-5914-89bd-4a2f98ec8534&assettype=image"><i class="fa fa-pencil-square"></i> Edit Image</a>
                    
                        <a class="btn btn-danger" href="https://elkodaily.com/users/admin/contribute/image/?from_section=/sports/football"><i class="fa fa-plus-square"></i> Add New Image</a>
                    
                </div>
                <div class="clearfix"></div>
            </div>
        </div><script>
        var oAuthors = [];jQuery(document).ready(function($){
            if( __tnt.user.loggedIn && jQuery.inArray(__tnt.user.screenName, oAuthors) !==-1 ){
                __tnt.isAuthor = true;
                $('.asset-owner-content').show();
            }
        });
    </script>
    
    

    
        
            <aside class="hidden-print offcanvas-drawer offcanvas-drawer-left ">
                <div id="tncms-region-mobile-nav-top-left-region" class="tncms-region "><div id="tncms-block-1466055" class="tncms-block site-brand-mark"><section id="block-1466055" class="block emphasis-h3   " ><div class="block">
        <a href="/" >
            <img src="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/custom/image/f67b64ca-6cae-11e7-bd21-7fd6fd615faa.png?_dc=1500488437" class="img-responsive" alt="">
        </a>
    </div></section></div><div id="tncms-block-1466116" class="tncms-block site-follow-us"><div class="follow-links-1466116 default">
    
    <section id="block-1466116" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/elkodaily/" title="Facebook" target="_blank" class="btn btn-xs btn-link fb">
                    <i class="fa fa-facebook"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/elkodaily" title="Twitter" target="_blank" class="btn btn-xs btn-link tw">
                    <i class="fa fa-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
            <li>
                <a href="https://www.youtube.com/user/ElkoDaily" title="Youtube" target="_blank" class="btn btn-xs btn-link yt">
                    <i class="fa fa-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "http://schema.org",
  "@type" : "Organization",
  "url" : "http://elkodaily.com",
  "sameAs" : ["https://www.facebook.com/elkodaily/","https://twitter.com/elkodaily","https://www.youtube.com/user/ElkoDaily"] 
}
</script>
<div class="clearfix"></div></div><div id="tncms-block-1466051" class="tncms-block"><div id="user-controls-1466051" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://elkodaily.com/users/signup/?referer_url=http%3A%2F%2Felkodaily.com%2Fsports%2Ffootball%2Fthe-high-profile-cuts-speaking-of-mathieu-he-s-one%2Fimage_ce623af1-32eb-5914-89bd-4a2f98ec8534.html%3Fsrc%3Drss" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://elkodaily.com/users/login/?referer_url=http%3A%2F%2Felkodaily.com%2Fsports%2Ffootball%2Fthe-high-profile-cuts-speaking-of-mathieu-he-s-one%2Fimage_ce623af1-32eb-5914-89bd-4a2f98ec8534.html%3Fsrc%3Drss" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://elkodaily.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="jQuery('#user-logout-form-1466051').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" ><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li><a href="https://elkodaily.com/users/admin/" rel="nofollow"><i class="fa fa-fw fa-dashboard"></i> Dashboard</a></li>
                    <li><a class="tn-user-profile-url" href="" data-app="https://elkodaily.com/users/"><i class="fa fa-fw fa-user"></i> Profile</a></li>
                    <li><a href="https://elkodaily.com/users/admin/list/" rel="nofollow"><i class="fa fa-fw fa-bookmark"></i> Saved items</a></li>
                    <li role="presentation" class="divider"></li>
                    <li><a class="logout-btn" onclick="jQuery('#user-logout-form-1466051').submit(); return false;" rel="nofollow"><i class="fa fa-fw fa-power-off"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://elkodaily.com/users/logout/" id="user-logout-form-1466051"><input type="hidden" name="referer_url" value="http://elkodaily.com/sports/football/the-high-profile-cuts-speaking-of-mathieu-he-s-one/image_ce623af1-32eb-5914-89bd-4a2f98ec8534.html?src=rss"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-left" class="tncms-region-nav"><div id="mobile-nav-left_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-1" data-target="#mobile-nav-left_menu-child-1">
                                    <i class="fa fa-chevron-down"></i>
                                </a><a href="/news" >
                                News
                            </a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="/news/local" >
                                        Local
                                    </a>
                                </li><li>
                                    <a href="/news/local/crime-and-courts" >
                                        Crime
                                    </a>
                                </li><li>
                                    <a href="/news/state-and-regional" >
                                        State & Regional
                                    </a>
                                </li><li>
                                    <a href="/lifestyles" >
                                        Lifestyles
                                    </a>
                                </li><li>
                                    <a href="/news/national" >
                                        National
                                    </a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-2" data-target="#mobile-nav-left_menu-child-2">
                                    <i class="fa fa-chevron-down"></i>
                                </a><a href="/obituaries" >
                                Obituaries
                            </a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/place_an_ad/obituaries" >
                                        Share a story
                                    </a>
                                </li><li>
                                    <a href="/obituaries" >
                                        Recent Obituaries
                                    </a>
                                </li><li>
                                    <a href="/obituaries/search/?c=lifestyles/announcements/obituaries*&t=article,collection" >
                                        Find an Obituary
                                    </a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-3" data-target="#mobile-nav-left_menu-child-3">
                                    <i class="fa fa-chevron-down"></i>
                                </a><a href="/opinion" >
                                Opinion
                            </a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/forms/contact/letter_to_the_editor/" >
                                        Submit a letter
                                    </a>
                                </li><li>
                                    <a href="/opinion/letters" >
                                        Letters
                                    </a>
                                </li><li>
                                    <a href="/opinion/editorial" >
                                        Editorial
                                    </a>
                                </li><li>
                                    <a href="/opinion/columnists" >
                                        Guest/Columnists
                                    </a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-4" data-target="#mobile-nav-left_menu-child-4">
                                    <i class="fa fa-chevron-down"></i>
                                </a><a href="/sports" >
                                Sports
                            </a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a href="/sports/high-school" >
                                        High School
                                    </a>
                                </li><li>
                                    <a href="/sports/national" >
                                        National
                                    </a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-5" data-target="#mobile-nav-left_menu-child-5">
                                    <i class="fa fa-chevron-down"></i>
                                </a><a href="/entertainment" >
                                Entertainment
                            </a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a href="/calendar" >
                                        Event Calendar
                                    </a>
                                </li><li>
                                    <a href="/entertainment/movies" >
                                        Movies
                                    </a>
                                </li><li>
                                    <a href="/entertainment/music" >
                                        Music
                                    </a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left_menu-child-6" data-target="#mobile-nav-left_menu-child-6">
                                    <i class="fa fa-chevron-down"></i>
                                </a><a href="/mining" >
                                Mining
                            </a>
                        </div>
                    </div><ul id="mobile-nav-left_menu-child-6" class="collapse nav navbar-nav"><li>
                                    <a href="/mining/quarterly" >
                                        Quarterly
                                    </a>
                                </li></ul></div></div></div>
                
                <div id="tncms-region-nav-mobile-nav-left-below" class="tncms-region-nav"><div id="mobile-nav-left-below_menu" class="panel-group nav navbar-nav" role="tablist"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left-below_menu-child-1" data-target="#mobile-nav-left-below_menu-child-1">
                                    <i class="fa fa-chevron-down"></i>
                                </a><a href="/eedition" >
                                Print Edition
                            </a>
                        </div>
                    </div><ul id="mobile-nav-left-below_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a href="/eedition" >
                                        E-edition
                                    </a>
                                </li><li>
                                    <a href="/circulars" >
                                        Weekly Ads
                                    </a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left-below_menu-child-2" data-target="#mobile-nav-left-below_menu-child-2">
                                    <i class="fa fa-chevron-down"></i>
                                </a><a href="/ads" >
                                Buy & Sell
                            </a>
                        </div>
                    </div><ul id="mobile-nav-left-below_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a href="/place_an_ad" >
                                        Place an Ad
                                    </a>
                                </li><li>
                                    <a href="/jobs" >
                                        Jobs
                                    </a>
                                </li><li>
                                    <a href="/homes" >
                                        Homes
                                    </a>
                                </li><li>
                                    <a href="/autos" >
                                        Cars
                                    </a>
                                </li><li>
                                    <a href="/ads" >
                                        Classifieds
                                    </a>
                                </li><li>
                                    <a href="/places" >
                                        Business Directory
                                    </a>
                                </li><li>
                                    <a href="/deals" >
                                        Today's Deal
                                    </a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-left-below_menu-child-3" data-target="#mobile-nav-left-below_menu-child-3">
                                    <i class="fa fa-chevron-down"></i>
                                </a><a href="/customer-service" >
                                Customer Service
                            </a>
                        </div>
                    </div><ul id="mobile-nav-left-below_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a href="/activate" >
                                        Manage My Account
                                    </a>
                                </li><li>
                                    <a href="/email" >
                                        Newsletter sign-up
                                    </a>
                                </li><li>
                                    <a href="/subscribenow" >
                                        Subscribe
                                    </a>
                                </li><li>
                                    <a href="/contact" >
                                        Contact us
                                    </a>
                                </li></ul></div></div></div>
                <div id="tncms-region-mobile-nav-bottom-left-region" class="tncms-region "><div id="tncms-block-1542025" class="tncms-block"><div class="mobile-nav-copyright">
<p>© 2018 Lee Enterprises</p>
<p><a href="/terms">Terms of Service</a>  |  <a href="/privacy">Privacy Policy</a></p>
</div></div></div>
            </aside>
        
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn"></div>
    

    

    

    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container">
                
                <div class="navbar-header">
                    
                    
                        <button type="button" class=" hamburger-desktop fluid-header navbar-toggle pull-left" data-toggle="offcanvas" data-target="left">
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="visible-lg visible-md sr-only-show">Menu</span>
                        </button>
                    
                    

                    
                        <div class="navbar-brand pos_left_menu_right_search">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-1466151" class="tncms-block"><section id="block-1466151" class="block emphasis-h3   " ><div class="block">
        <a href="/" >
            <img src="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/custom/image/a91ad5ce-67e7-11e7-a7c3-c70b99a8155d.png?_dc=1499963033" class="img-responsive" alt="">
        </a>
    </div></section></div></div>
                            
                        </div>
                    

                    
                        <ul class="hidden-md hidden-lg nav navbar-nav pull-right site-search-full-mobile">
                            <li class="search-form-dropdown dropdown yamm-fw">
                                <a class="dropdown-toggle" data-toggle="dropdown"><span class="fa fa-search"></span></a>
                                <ul class="dropdown-menu">
                                    <li>
                                        <form action="/search/" method="GET" class="yamm-content">
                                            <input type="hidden" name="l" value="25">
                                            <input type="hidden" name="sd" value="desc">
                                            <input type="hidden" name="s" value="start_time">
                                            <input type="hidden" name="f" value="html">
                                            <input type="hidden" name="t" value="article,video,youtube,collection">
                                            <div class="input-group">
                                                <input name="q" type="text" placeholder="Search..." class="form-control" autocomplete="off">
                                                <input type="submit" class="hide" value="Search">
                                                <span class="input-group-btn">
                                                    <button class="btn btn-default site-search-btn" type="submit">
                                                        Search
                                                    </button>
                                                </span>
                                            </div>
                                            <div class="clearfix"></div>
                                        </form>
                                    </li>
                                </ul>
                            </li>
                        </ul>
                        <script>
                            $('.site-search-full-mobile button[type="submit"]').on(__tnt.client.clickEvent, function(){
                                $('.site-search-full-mobile form').submit();
                                return false;
                            });                    
                        </script>                    
                                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-1466083" class="tncms-block"><ul id="site-search-1466083-dropdown" class="nav navbar-nav navbar-right site-search-full">
        <li class="search-form-dropdown dropdown yamm-fw">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle"  data-toggle="dropdown"><span class="fa fa-search"></span></a>
            <ul class="dropdown-menu">
                <li><form id="site-search-1466083" action="/search/" method="GET" class="yamm-content">
    <input type="hidden" name="sd" value="desc">
    <input type="hidden" name="l" value="25">
    
        <input type="hidden" name="s" value="start_time">
    
    
    
    <input type="hidden" name="f" value="html">
    <input type="hidden" name="t" value="article,video,youtube,collection">
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal ">
        <input id="site-search-1466083-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-1466083-btn" class="btn btn-primary" type="submit">
                <span class="hidden-xs hidden-sm">Search</span>
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-1466083-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-1466083').submit();
        return false;
    });

    $('#site-search-1466083').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-1466083 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-1466083 input[name=q]").val( sQueryFiltered );
                
        if( $('#site-search-1466083-term').val() ){
            $('#site-search-1466083-btn .fa').removeClass('fa-search').addClass('fa-spinner fa-spin');
            return true;
        }else{
            return false;
        }
    });</script></div><div id="tncms-block-1466084" class="tncms-block"><div id="user-controls-1466084" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="nav navbar-nav navbar-right"><li><a  onclick="javascript:void(0); return false;"  data-toggle="dropdown"  class="user-control-link" rel="nofollow">
                        <span class="fa fa-user"></span>
                    </a>
                    <ul class="dropdown-menu dropdown-menu-right" role="menu">
                        <li>
                            <div style="width: 300px; padding: 15px">
                                <div class="row padding-bottom">
                                    <div class="col-md-12">
                                        <h4>Log In Using Your Account</h4>
                                        <a class="btn btn-block btn-primary" href="https://elkodaily.com/users/login/?referer_url=http%3A%2F%2Felkodaily.com%2Fsports%2Ffootball%2Fthe-high-profile-cuts-speaking-of-mathieu-he-s-one%2Fimage_ce623af1-32eb-5914-89bd-4a2f98ec8534.html%3Fsrc%3Drss" rel="nofollow">Log In</a>
                                    </div>
                                </div>
                                <div class="row">
                                    <div class="col-md-12">
                                        <div class="dropdown-signup"><strong>Don't have an account?</strong> <a href="https://elkodaily.com/users/signup/?referer_url=http%3A%2F%2Felkodaily.com%2Fsports%2Ffootball%2Fthe-high-profile-cuts-speaking-of-mathieu-he-s-one%2Fimage_ce623af1-32eb-5914-89bd-4a2f98ec8534.html%3Fsrc%3Drss" rel="nofollow">Sign Up Today</a></div>
                                    </div>
                                </div>
                            </div>
                        </li>
                    </ul>
                </li>
        </ul>
    </div>

    <div class="logged-in">
        
        
        <ul class="nav navbar-nav navbar-right">
            <li class="dropdown pull-right">
                
                <a class="dropdown-toggle  user-dropdown" data-toggle="dropdown" ><div class="tn-user-avatar pull-left"><!-- user avatar --></div><b class="caret user-control-link"></b>
                </a>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li><a href="https://elkodaily.com/users/admin/" rel="nofollow"><i class="fa fa-fw fa-dashboard"></i> Dashboard</a></li>
                    <li><a class="tn-user-profile-url" href="" data-app="https://elkodaily.com/users/"><i class="fa fa-fw fa-user"></i> Profile</a></li>
                    <li><a href="https://elkodaily.com/users/admin/list/" rel="nofollow"><i class="fa fa-fw fa-bookmark"></i> Saved items</a></li>
                    <li role="presentation" class="divider"></li>
                    <li><a class="logout-btn" onclick="jQuery('#user-logout-form-1466084').submit(); return false;" rel="nofollow"><i class="fa fa-fw fa-power-off"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://elkodaily.com/users/logout/" id="user-logout-form-1466084"><input type="hidden" name="referer_url" value="http://elkodaily.com/sports/football/the-high-profile-cuts-speaking-of-mathieu-he-s-one/image_ce623af1-32eb-5914-89bd-4a2f98ec8534.html?src=rss"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-1466085" class="tncms-block"><div id="weather-1466085" class="weather-current size-nav pull-left">
    <ul class="nav navbar-nav navbar-right">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip=89801" class="dropdown-toggle" data-toggle="dropdown" >
                <span class="icon pull-left">
                    
                    <span class="wi-day-cloudy"></span>
                </span>
                <span class="pull-left temp-desc nav">
                    <span class="temp">35&deg;</span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu" aria-labelledby="weatherExpanded">
                    <li>
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value="89801"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" onclick="jQuery('#weather-1466085 .zip-update-form').toggle('fast'); return false;"><span class="fa fa-cog"></span></a>

                            <h4 class="city-title"><i class="fa fa-map-marker"></i>
                                
                                    Elko, NV
                                
                                 <small>(89801)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Snow showers becoming mixed with rain later. Thunder possible. High 44F. Winds S at 10 to 15 mph. Chance of rain 70%..</p>
                            <h5>Tonight</h5>
                            <p>Snow this evening will give way to lingering snow showers late. Low around 25F. Winds WSW at 5 to 10 mph. Chance of snow 80%. Snow accumulating 1 to 3 inches.</p>
                            <p class="text-center"><small><i class="fa fa-info-circle"></i> Updated: March 16, 2018 @ 8:56 am</small></p>
                        </div>
                    </li>
                    <li role="presentation" class="divider"></li>
                    <li class="forecast-link text-center"><a href="/weather/?weather_zip=89801"><i class="fa fa-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>
</div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav"><li>
                <a class="nav-link"  href="/news/" >
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link"  href="/obituaries" >
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link"  href="/sports/" >
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link"  href="/eedition" >
                    <span class="nav-label">E-edition</span>
                </a></li><li>
                <a class="nav-link"  href="/ads/" >
                    <span class="nav-label">Buy & Sell</span>
                </a></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
        </div>
        
            
                <script>
                    jQuery(document).ready(function($){
                        var sNavContainer = '#site-navbar-container';
                        var sBodyContainer = '#main-body-container';
                        var sNavHeight = $(sNavContainer).height();
                        var iUnfixPoint = 0;
                        if( __tnt.client.platform.ios ){
                            $(sNavContainer).addClass('affix-sticky');
                        } else {
                            $sNavScroll = false;
                            $(window).on('scroll mousewheel', function(){
                                if( !$sNavScroll ){
                                    $sNavScroll = true;
                                    setTimeout(function(){
                                        var iFixPoint = $(sNavContainer).offset().top;
                                        var iCurrPoint = $(this).scrollTop();
                                        if( iCurrPoint >= iFixPoint && iCurrPoint > iUnfixPoint ){
                                            if( !$(sNavContainer).hasClass('affix') ){ 
                                                iUnfixPoint = iFixPoint;
                                                $(sNavContainer).addClass('affix').removeClass('affix-top');
                                                $(sBodyContainer).css('margin-top', sNavHeight+'px'); 
                                            }
                                        } else {
                                            if( !$(sNavContainer).hasClass('affix-top') ){ 
                                                $(sNavContainer).removeClass('affix').addClass('affix-top');
                                                $(sBodyContainer).css('margin-top', 0);
                                            }
                                        }
                                        $sNavScroll = false;
                                    }, 25);
                                }
                            });
                        }
                    });
                </script>
            
        
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-1466086" class="tncms-block lee-track-home-breaking"><section id="block-1466086" class="block emphasis-h3 light  " >
        <div class="breaking">
            <div class="breaking-container clearfix">
                <div id="breaking-title-1466086" class="breaking-title text-center light" >
                    <h4>Breaking</h4>
                </div>
                <div id="breaking-content-1466086" class="breaking-content card-img-sm card-compact card-bg-color">
                    
                        
                            <article id="card-summary-1466086-5a1cfd58-b373-512f-9e94-8a42bf4f1eb2" class="clearfix card summary  card-section-news-local">
            <div class="card-container">
                
                <div class="card-body">
                    
                    
                    <div class="card-headline">
                        <h3 class="">
        
             <a href="/news/local/snow-forecast-upgraded-to-winter-storm-warning/article_5a1cfd58-b373-512f-9e94-8a42bf4f1eb2.html">
        

        
        Snow forecast upgraded to winter storm warning</a></h3>
                    </div>
                    
                    
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                        
                    
                </div>
            </div>
        </div>
    </section>
    </div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
        <div class="container-breakout">
        <div class="visible-lg visible-md"><div class="tnt-ads-container text-center hidden-xs"><div style="min-height:90px; min-width:728px;" class="tnt-ads dfp-ad" data-dfp-adunit="/8438/elkodaily.com/sports/football" data-dfp-custom-pos="fixed-leaderboard-top, atf, 50" id="fixed-leaderboard-top" data-dfp-size="[[728,90], [970,90], [970,250]]"></div></div>
    </div><div class="visible-sm"><div class="tnt-ads-container text-center hidden-xs"><div style="min-height:90px; min-width:728px;" class="tnt-ads dfp-ad" data-dfp-adunit="/8438/elkodaily.com/sports/football" data-dfp-custom-pos="fixed-leaderboard-top, atf, 50" id="fixed-leaderboard-top-tablet" data-dfp-size="[728,90]"></div></div>
    </div><div class="tnt-ads-container text-center hidden-sm hidden-md hidden-lg"><div style="min-height:50px; min-width:320px;" class="tnt-ads dfp-ad" data-dfp-adunit="/8438/elkodaily.com/sports/football" data-dfp-custom-pos="fixed-leaderboard-top, atf, 50" id="fixed-leaderboard-top-mobile" data-dfp-size="[320,50]"></div></div>
    
       </div>
                <div id="asset-container-top" class="col-md-12">
                    <div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div> 
                </div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "></div></div>
        </div><article id="asset-ce623af1-32eb-5914-89bd-4a2f98ec8534" class="asset image-default">
    <header class="asset-header">
    
        <div class="asset-label-flags">
            <span class="label label-flag label-flag-default label-flag-ap">AP</span> 
        </div>
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            2. The high-profile cuts

Speaking of Mathieu, he's one of several established stars to hit the open market with plenty of gas left in the tank. Veterans who are available into the second and third waves of free agency, never mind the ones cut as the proceedings are getting underway, generally have non-football concerns — whether they're related to contract, durability or off-field questions.

But Mathieu led the NFL in defensive snaps last season, just one removed from his second major knee injury, and has already proven he's one of the game's more perseverant players. He's also one of its most versatile and exciting, and we can't think of too many defenses that shouldn't want to find a place for him.

While "Honey Badger" comes with a durability buyer beware tag, Ndamukong Suh's issues are very different. He's missed just two games in his first eight seasons, including a Defensive Rookie of the Year and five All-Pro nominations. He can still be a dominant player — when he wants to.

Indeed, the factor clubs considering Suh must weigh — and, like Mathieu, there aren't many defenses that couldn't use Suh's services — is his motor and motivation. One of the NFL's best businessmen — Suh has cashed $124 million already in his NFL career — made no bones about the fact in a conversation with ESPN on Wednesday that his next team will be the one willing to offer him the most financially. Forget fit. Forget finally winning in the postseason, which Suh has yet to do in three games over eight seasons.

Perhaps neither of these players are for everyone, then, but they're both special talents who still will command big contracts, which is a bit unusual at this juncture of free agency.
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li><time datetime="2018-03-15T15:22:00-07:00" class="asset-date text-muted">
            Mar 15, 2018
        </time><span class="text-muted">Updated </span><time datetime="2018-03-15T22:17:14-07:00" class="asset-date text-muted">11 hrs ago</time>
    </li>
        
        
            <li class="hidden-print"><a href="/sports/football/the-high-profile-cuts-speaking-of-mathieu-he-s-one/image_ce623af1-32eb-5914-89bd-4a2f98ec8534.html#comments" class="cm" title="0 comments"><span class="fa fa-comments"></span> <span class="count">0</span></a>
</li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2018-03-15T15:22:00-07:00">
    <meta itemprop="datePublished" content="2018-03-15T15:22:00-07:00">
    <meta itemprop="dateModified" content="2018-03-15T15:17:14-07:00">
</header>
    <div class="row">
        <div class="main-content col-lg-8 col-md-7">
            <div class="main-content-wrap">
            
            
            
                <div class="share-container content-above">
                    
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Felkodaily.com%2Fsports%2Ffootball%2Fthe-high-profile-cuts-speaking-of-mathieu-he-s-one%2Fimage_ce623af1-32eb-5914-89bd-4a2f98ec8534.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/football/the-high-profile-cuts-speaking-of-mathieu-he-s-one/image_ce623af1-32eb-5914-89bd-4a2f98ec8534.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":ce623af1-32eb-5914-89bd-4a2f98ec8534}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
            
                <span class="fa-stack" >
                    
                    <i class="fa fa-facebook fa-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Felkodaily.com%2Fsports%2Ffootball%2Fthe-high-profile-cuts-speaking-of-mathieu-he-s-one%2Fimage_ce623af1-32eb-5914-89bd-4a2f98ec8534.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share&text=2.%20The%20high-profile%20cuts%0A%0ASpeaking%20of%20Mathieu%2C%20he%27s%20one%20of%20several%20established%20stars%20to%20hit%20the%20open%20market%20with%20plenty%20of%20gas%20left%20in%20the%20tank.%20Veterans%20who%20are%20available%20into%20the%20second%20and%20third%20waves%20of%20free%20agency%2C%20never%20mind%20the%20ones%20cut%20as%20the%20proceedings%20are%20getting%20underway%2C%20generally%20have%20non-football%20concerns%20%E2%80%94%20whether%20they%27re%20related%20to%20contract%2C%20durability%20or%20off-field%20questions.%0A%0ABut%20Mathieu%20led%20the%20NFL%20in%20defensive%20snaps%20last%20season%2C%20just%20one%20removed%20from%20his%20second%20major%20knee%20injury%2C%20and%20has%20already%20proven%20he%27s%20one%20of%20the%20game%27s%20more%20perseverant%20players.%20He%27s%20also%20one%20of%20its%20most%20versatile%20and%20exciting%2C%20and%20we%20can%27t%20think%20of%20too%20many%20defenses%20that%20shouldn%27t%20want%20to%20find%20a%20place%20for%20him.%0A%0AWhile%20%22Honey%20Badger%22%20comes%20with%20a%20durability%20buyer%20beware%20tag%2C%20Ndamukong%20Suh%27s%20issues%20are%20very%20different.%20He%27s%20missed%20just%20two%20games%20in%20his%20first%20eight%20seasons%2C%20including%20a%20Defensive%20Rookie%20of%20the%20Year%20and%20five%20All-Pro%20nominations.%20He%20can%20still%20be%20a%20dominant%20player%20%E2%80%94%20when%20he%20wants%20to.%0A%0AIndeed%2C%20the%20factor%20clubs%20considering%20Suh%20must%20weigh%20%E2%80%94%20and%2C%20like%20Mathieu%2C%20there%20aren%27t%20many%20defenses%20that%20couldn%27t%20use%20Suh%27s%20services%20%E2%80%94%20is%20his%20motor%20and%20motivation.%20One%20of%20the%20NFL%27s%20best%20businessmen%20%E2%80%94%20Suh%20has%20cashed%20%24124%20million%20already%20in%20his%20NFL%20career%20%E2%80%94%20made%20no%20bones%20about%20the%20fact%20in%20a%20conversation%20with%20ESPN%20on%20Wednesday%20that%20his%20next%20team%20will%20be%20the%20one%20willing%20to%20offer%20him%20the%20most%20financially.%20Forget%20fit.%20Forget%20finally%20winning%20in%20the%20postseason%2C%20which%20Suh%20has%20yet%20to%20do%20in%20three%20games%20over%20eight%20seasons.%0A%0APerhaps%20neither%20of%20these%20players%20are%20for%20everyone%2C%20then%2C%20but%20they%27re%20both%20special%20talents%20who%20still%20will%20command%20big%20contracts%2C%20which%20is%20a%20bit%20unusual%20at%20this%20juncture%20of%20free%20agency.&via=elkodaily" class="tw" target="_blank" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/football/the-high-profile-cuts-speaking-of-mathieu-he-s-one/image_ce623af1-32eb-5914-89bd-4a2f98ec8534.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":ce623af1-32eb-5914-89bd-4a2f98ec8534}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                <span class="fa-stack" >
                    
                    <i class="fa fa-twitter fa-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BElko%20Daily%20Free%20Press%5D%202.%20The%20high-profile%20cuts%0A%0ASpeaking%20of%20Mathieu%2C%20he%27s%20one%20of%20several%20established%20stars%20to%20hit%20the%20open%20market%20with%20plenty%20of%20gas%20left%20in%20the%20tank.%20Veterans%20who%20are%20available%20into%20the%20second%20and%20third%20waves%20of%20free%20agency%2C%20never%20mind%20the%20ones%20cut%20as%20the%20proceedings%20are%20getting%20underway%2C%20generally%20have%20non-football%20concerns%20%E2%80%94%20whether%20they%27re%20related%20to%20contract%2C%20durability%20or%20off-field%20questions.%0A%0ABut%20Mathieu%20led%20the%20NFL%20in%20defensive%20snaps%20last%20season%2C%20just%20one%20removed%20from%20his%20second%20major%20knee%20injury%2C%20and%20has%20already%20proven%20he%27s%20one%20of%20the%20game%27s%20more%20perseverant%20players.%20He%27s%20also%20one%20of%20its%20most%20versatile%20and%20exciting%2C%20and%20we%20can%27t%20think%20of%20too%20many%20defenses%20that%20shouldn%27t%20want%20to%20find%20a%20place%20for%20him.%0A%0AWhile%20%22Honey%20Badger%22%20comes%20with%20a%20durability%20buyer%20beware%20tag%2C%20Ndamukong%20Suh%27s%20issues%20are%20very%20different.%20He%27s%20missed%20just%20two%20games%20in%20his%20first%20eight%20seasons%2C%20including%20a%20Defensive%20Rookie%20of%20the%20Year%20and%20five%20All-Pro%20nominations.%20He%20can%20still%20be%20a%20dominant%20player%20%E2%80%94%20when%20he%20wants%20to.%0A%0AIndeed%2C%20the%20factor%20clubs%20considering%20Suh%20must%20weigh%20%E2%80%94%20and%2C%20like%20Mathieu%2C%20there%20aren%27t%20many%20defenses%20that%20couldn%27t%20use%20Suh%27s%20services%20%E2%80%94%20is%20his%20motor%20and%20motivation.%20One%20of%20the%20NFL%27s%20best%20businessmen%20%E2%80%94%20Suh%20has%20cashed%20%24124%20million%20already%20in%20his%20NFL%20career%20%E2%80%94%20made%20no%20bones%20about%20the%20fact%20in%20a%20conversation%20with%20ESPN%20on%20Wednesday%20that%20his%20next%20team%20will%20be%20the%20one%20willing%20to%20offer%20him%20the%20most%20financially.%20Forget%20fit.%20Forget%20finally%20winning%20in%20the%20postseason%2C%20which%20Suh%20has%20yet%20to%20do%20in%20three%20games%20over%20eight%20seasons.%0A%0APerhaps%20neither%20of%20these%20players%20are%20for%20everyone%2C%20then%2C%20but%20they%27re%20both%20special%20talents%20who%20still%20will%20command%20big%20contracts%2C%20which%20is%20a%20bit%20unusual%20at%20this%20juncture%20of%20free%20agency.&body=http%3A%2F%2Felkodaily.com%2Fsports%2Ffootball%2Fthe-high-profile-cuts-speaking-of-mathieu-he-s-one%2Fimage_ce623af1-32eb-5914-89bd-4a2f98ec8534.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":ce623af1-32eb-5914-89bd-4a2f98ec8534}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="fa-stack" >
                
                <i class="fa fa-envelope fa-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/football/the-high-profile-cuts-speaking-of-mathieu-he-s-one/image_ce623af1-32eb-5914-89bd-4a2f98ec8534.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":ce623af1-32eb-5914-89bd-4a2f98ec8534}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="fa-stack" >
                        
                        <i class="fa fa-print fa-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link">
        <a class="save-list-ce623af1-32eb-5914-89bd-4a2f98ec8534-btn save-asset " onclick="jQuery('.save-list-ce623af1-32eb-5914-89bd-4a2f98ec8534-form').submit(); return false;" title="Save to list" href="#"  role="button" rel="nofollow">
            <span class="fa-stack">
                
                <i class="asset-save-icon fa fa-bookmark-o fa-stack-1x"></i>
            </span>
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul>
    <form method="post" data-uuid="ce623af1-32eb-5914-89bd-4a2f98ec8534" class="save-list-ce623af1-32eb-5914-89bd-4a2f98ec8534-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="ce623af1-32eb-5914-89bd-4a2f98ec8534" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                </div>
            

            <div id="asset-content" data-asset-uuid="ce623af1-32eb-5914-89bd-4a2f98ec8534">
                <div class=" p402_hide subscriber-hide"><figure class="photo layout-horizontal"
            >
            <div class="image">
                
                
                
                
        <div itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
            <meta itemprop="width" content="1024">
            <meta itemprop="height" content="691">
            <meta itemprop="contentUrl" content="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/assets/v3/editorial/c/e6/ce623af1-32eb-5914-89bd-4a2f98ec8534/5aaaa8f4281f7.image.jpg">
            <meta itemprop="url" content="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/assets/v3/editorial/c/e6/ce623af1-32eb-5914-89bd-4a2f98ec8534/5aaaa8f4281f7.image.jpg">
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="2. The high-profile cuts

Speaking of Mathieu, he's one of several established stars to hit the open market with plenty of gas left in the tank. Veterans who are available into the second and third waves of free agency, never mind the ones cut as the proceedings are getting underway, generally have non-football concerns — whether they're related to contract, durability or off-field questions.

But Mathieu led the NFL in defensive snaps last season, just one removed from his second major knee injury, and has already proven he's one of the game's more perseverant players. He's also one of its most versatile and exciting, and we can't think of too many defenses that shouldn't want to find a place for him.

While &quot;Honey Badger&quot; comes with a durability buyer beware tag, Ndamukong Suh's issues are very different. He's missed just two games in his first eight seasons, including a Defensive Rookie of the Year and five All-Pro nominations. He can still be a dominant player — when he wants to.

Indeed, the factor clubs considering Suh must weigh — and, like Mathieu, there aren't many defenses that couldn't use Suh's services — is his motor and motivation. One of the NFL's best businessmen — Suh has cashed $124 million already in his NFL career — made no bones about the fact in a conversation with ESPN on Wednesday that his next team will be the one willing to offer him the most financially. Forget fit. Forget finally winning in the postseason, which Suh has yet to do in three games over eight seasons.

Perhaps neither of these players are for everyone, then, but they're both special talents who still will command big contracts, which is a bit unusual at this juncture of free agency."
                        class="img-responsive lazyload ap-photo full"
                        width="1024"
                        height="691"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/assets/v3/editorial/c/e6/ce623af1-32eb-5914-89bd-4a2f98ec8534/5aaaa8f4281f7.image.jpg?resize=200%2C135 200w, https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/assets/v3/editorial/c/e6/ce623af1-32eb-5914-89bd-4a2f98ec8534/5aaaa8f4281f7.image.jpg?resize=300%2C202 300w, https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/assets/v3/editorial/c/e6/ce623af1-32eb-5914-89bd-4a2f98ec8534/5aaaa8f4281f7.image.jpg?resize=400%2C270 400w, https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/assets/v3/editorial/c/e6/ce623af1-32eb-5914-89bd-4a2f98ec8534/5aaaa8f4281f7.image.jpg?resize=540%2C364 540w, https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/assets/v3/editorial/c/e6/ce623af1-32eb-5914-89bd-4a2f98ec8534/5aaaa8f4281f7.image.jpg?resize=750%2C506 750w, https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/assets/v3/editorial/c/e6/ce623af1-32eb-5914-89bd-4a2f98ec8534/5aaaa8f4281f7.image.jpg 1200w" />
            </div>
                
            </div>
            
                
                
                    <figcaption class="caption">
                            <span class="caption-text">
                                <p>2. The high-profile cuts Speaking of Mathieu, he's one of several established stars to hit the open market with plenty of gas left in the tank. Veterans who are available into the second and third waves of free agency, never mind the ones cut as the proceedings are getting underway, generally have non-football concerns — whether they're related to contract, durability or off-field questions. But Mathieu led the NFL in defensive snaps last season, just one removed from his second major knee injury, and has already proven he's one of the game's more perseverant players. He's also one of its most versatile and exciting, and we can't think of too many defenses that shouldn't want to find a place for him. While "Honey Badger" comes with a durability buyer beware tag, Ndamukong Suh's issues are very different. He's missed just two games in his first eight seasons, including a Defensive Rookie of the Year and five All-Pro nominations. He can still be a dominant player — when he wants to. Indeed, the factor clubs considering Suh must weigh — and, like Mathieu, there aren't many defenses that couldn't use Suh's services — is his motor and motivation. One of the NFL's best businessmen — Suh has cashed $124 million already in his NFL career — made no bones about the fact in a conversation with ESPN on Wednesday that his next team will be the one willing to offer him the most financially. Forget fit. Forget finally winning in the postseason, which Suh has yet to do in three games over eight seasons. Perhaps neither of these players are for everyone, then, but they're both special talents who still will command big contracts, which is a bit unusual at this juncture of free agency.</p>
                            </span>
                        
                        
                    </figcaption>
                
            
        </figure>
                <div class="asset-syndicated-ads">
            <div class="row">
                <div class=" col-lg-6 col-md-12 col-sm-6  col-xs-12 asset-syndicated-ad-one"><div class="tnt-ads-container text-center "><div style="min-height:250px; min-width:300px;" class="tnt-ads dfp-ad" data-dfp-adunit="/132916964/profootballweekly.com/cen" data-dfp-custom-pos="fixed-asset-syndicated-one, atf" id="fixed-asset-syndicated-one" data-dfp-size="[300,250]" data-lazy="true"></div></div>
    
                </div>
                
                    <div class="col-lg-6 col-md-12 col-sm-6 col-xs-12 asset-syndicated-ad-two"><div class="tnt-ads-container text-center hidden-xs"><div style="min-height:250px; min-width:300px;" class="tnt-ads dfp-ad" data-dfp-adunit="/132916964/profootballweekly.com/cen" data-dfp-custom-pos="fixed-asset-syndicated-two, atf" id="fixed-asset-syndicated-two" data-dfp-size="[300,250]" data-lazy="true"></div></div>
    </div>
                
                <div class="col-xs-12">
                    <div class="asset-syndicated-ad-tagline text-muted text-right">
                    <small><em>TownNews.com Content Exchange</em></small>
                    </div>
                </div>
            </div>
        </div>
                
                    <div class="asset-tags hidden-print">
                        <h4>Tags</h4>
                        <ul class="list-inline"><li>
                <a href="/search/?k=%22wire%22#tncms-source=keyword" class="tag-wire label label-default" data-tncms-track-dmp='search: wire'>Wire</a>
            </li> </ul>
                    </div>
                
                
                
                
                <div class="visible-lg visible-sm"><div class="tnt-ads-container text-center "><div style="min-height:250px; min-width:620px;" class="tnt-ads dfp-ad" data-dfp-adunit="/8438/elkodaily.com/sports/football" data-dfp-custom-pos="article_links_1, btf, 50" id="article_links_1" data-dfp-size="[620,250]" data-lazy="true"></div></div>
    </div><div class="visible-md visible-xs"><div class="tnt-ads-container text-center "><div style="min-height:250px; min-width:300px;" class="tnt-ads dfp-ad" data-dfp-adunit="/8438/elkodaily.com/sports/football" data-dfp-custom-pos="article_links_1, btf, 50" id="article_links_1_sm" data-dfp-size="[300,250]" data-lazy="true"></div></div>
    </div>
                

<div class="asset-related">



    <div class="asset-related-group parents">
        <h4 class="text-muted">As featured on</h4>
        <div class="related-content">
            <div class="row">
                
                        
                        <div class="col-sm-12">
                            <article id="card-summary-715324f4-f1b7-5625-9d95-8f865c8fa200" class="clearfix card summary has-image image-top  card-section-sports-football">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-715324f4-f1b7-5625-9d95-8f865c8fa200 media-preview article-asset" data-aspect=""><figure class="photo layout-horizontal"
            >
            <div class="image">
                
                    <a href="/sports/football/arthur-arkush-s-five-early-free-agent-observations/article_715324f4-f1b7-5625-9d95-8f865c8fa200.html">
                
                
                    <div class="asset-icon"><i class="fa fa-camera fa-fw" title="Article with images"></i> +5</div>
                
                
                
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                        alt="Arthur Arkush's five early free-agent observations"
                        class="img-responsive lazyload ap-photo full"
                        width="1024"
                        height="736"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/assets/v3/editorial/e/49/e498609a-9e38-56e8-b47b-e89a319a2e5f/5aaaa8f3a433b.image.jpg?resize=200%2C144 200w, https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/assets/v3/editorial/e/49/e498609a-9e38-56e8-b47b-e89a319a2e5f/5aaaa8f3a433b.image.jpg?resize=300%2C216 300w, https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/assets/v3/editorial/e/49/e498609a-9e38-56e8-b47b-e89a319a2e5f/5aaaa8f3a433b.image.jpg?resize=400%2C288 400w, https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/assets/v3/editorial/e/49/e498609a-9e38-56e8-b47b-e89a319a2e5f/5aaaa8f3a433b.image.jpg?resize=540%2C388 540w, https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/assets/v3/editorial/e/49/e498609a-9e38-56e8-b47b-e89a319a2e5f/5aaaa8f3a433b.image.jpg?resize=750%2C539 750w, https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/assets/v3/editorial/e/49/e498609a-9e38-56e8-b47b-e89a319a2e5f/5aaaa8f3a433b.image.jpg 1200w" />
                </a>
            </div>
            
        </figure>
    </div>
                    </div>
                
                <div class="card-body">
                    
                    
                    <div class="card-headline">
                        <h3 class="">
        
             <a href="/sports/football/arthur-arkush-s-five-early-free-agent-observations/article_715324f4-f1b7-5625-9d95-8f865c8fa200.html">
        

        
        Arthur Arkush's five early free-agent observations</a></h3>
                    </div>
                    
                    
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p><p>Here are five general observations from Arthur Arkush about the start of a frenzied free-agent period:</p></p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                        </div>
                        
                    
                    
                
            </div>
        </div>
    </div>



</div>

                <div id="tncms-region-other_asset_bottom" class="tncms-region hidden-print"></div>  
                </div><!-- /subscriber hide -->
                
                
                    <div class="share-container content-below">
                        
    <ul class="social-share-links hidden-print list-inline icon">
        <li class="social-share-link">
         
            <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Felkodaily.com%2Fsports%2Ffootball%2Fthe-high-profile-cuts-speaking-of-mathieu-he-s-one%2Fimage_ce623af1-32eb-5914-89bd-4a2f98ec8534.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="fb" target="_blank" title="Share on Facebook" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/football/the-high-profile-cuts-speaking-of-mathieu-he-s-one/image_ce623af1-32eb-5914-89bd-4a2f98ec8534.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":ce623af1-32eb-5914-89bd-4a2f98ec8534}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
            
                <span class="fa-stack" >
                    
                    <i class="fa fa-facebook fa-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link">
            <a href="https://twitter.com/intent/tweet?url=http%3A%2F%2Felkodaily.com%2Fsports%2Ffootball%2Fthe-high-profile-cuts-speaking-of-mathieu-he-s-one%2Fimage_ce623af1-32eb-5914-89bd-4a2f98ec8534.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share&text=2.%20The%20high-profile%20cuts%0A%0ASpeaking%20of%20Mathieu%2C%20he%27s%20one%20of%20several%20established%20stars%20to%20hit%20the%20open%20market%20with%20plenty%20of%20gas%20left%20in%20the%20tank.%20Veterans%20who%20are%20available%20into%20the%20second%20and%20third%20waves%20of%20free%20agency%2C%20never%20mind%20the%20ones%20cut%20as%20the%20proceedings%20are%20getting%20underway%2C%20generally%20have%20non-football%20concerns%20%E2%80%94%20whether%20they%27re%20related%20to%20contract%2C%20durability%20or%20off-field%20questions.%0A%0ABut%20Mathieu%20led%20the%20NFL%20in%20defensive%20snaps%20last%20season%2C%20just%20one%20removed%20from%20his%20second%20major%20knee%20injury%2C%20and%20has%20already%20proven%20he%27s%20one%20of%20the%20game%27s%20more%20perseverant%20players.%20He%27s%20also%20one%20of%20its%20most%20versatile%20and%20exciting%2C%20and%20we%20can%27t%20think%20of%20too%20many%20defenses%20that%20shouldn%27t%20want%20to%20find%20a%20place%20for%20him.%0A%0AWhile%20%22Honey%20Badger%22%20comes%20with%20a%20durability%20buyer%20beware%20tag%2C%20Ndamukong%20Suh%27s%20issues%20are%20very%20different.%20He%27s%20missed%20just%20two%20games%20in%20his%20first%20eight%20seasons%2C%20including%20a%20Defensive%20Rookie%20of%20the%20Year%20and%20five%20All-Pro%20nominations.%20He%20can%20still%20be%20a%20dominant%20player%20%E2%80%94%20when%20he%20wants%20to.%0A%0AIndeed%2C%20the%20factor%20clubs%20considering%20Suh%20must%20weigh%20%E2%80%94%20and%2C%20like%20Mathieu%2C%20there%20aren%27t%20many%20defenses%20that%20couldn%27t%20use%20Suh%27s%20services%20%E2%80%94%20is%20his%20motor%20and%20motivation.%20One%20of%20the%20NFL%27s%20best%20businessmen%20%E2%80%94%20Suh%20has%20cashed%20%24124%20million%20already%20in%20his%20NFL%20career%20%E2%80%94%20made%20no%20bones%20about%20the%20fact%20in%20a%20conversation%20with%20ESPN%20on%20Wednesday%20that%20his%20next%20team%20will%20be%20the%20one%20willing%20to%20offer%20him%20the%20most%20financially.%20Forget%20fit.%20Forget%20finally%20winning%20in%20the%20postseason%2C%20which%20Suh%20has%20yet%20to%20do%20in%20three%20games%20over%20eight%20seasons.%0A%0APerhaps%20neither%20of%20these%20players%20are%20for%20everyone%2C%20then%2C%20but%20they%27re%20both%20special%20talents%20who%20still%20will%20command%20big%20contracts%2C%20which%20is%20a%20bit%20unusual%20at%20this%20juncture%20of%20free%20agency.&via=elkodaily" class="tw" target="_blank" title="Tweet" data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/football/the-high-profile-cuts-speaking-of-mathieu-he-s-one/image_ce623af1-32eb-5914-89bd-4a2f98ec8534.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":ce623af1-32eb-5914-89bd-4a2f98ec8534}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                <span class="fa-stack" >
                    
                    <i class="fa fa-twitter fa-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link">
            <a href="mailto:?subject=%5BElko%20Daily%20Free%20Press%5D%202.%20The%20high-profile%20cuts%0A%0ASpeaking%20of%20Mathieu%2C%20he%27s%20one%20of%20several%20established%20stars%20to%20hit%20the%20open%20market%20with%20plenty%20of%20gas%20left%20in%20the%20tank.%20Veterans%20who%20are%20available%20into%20the%20second%20and%20third%20waves%20of%20free%20agency%2C%20never%20mind%20the%20ones%20cut%20as%20the%20proceedings%20are%20getting%20underway%2C%20generally%20have%20non-football%20concerns%20%E2%80%94%20whether%20they%27re%20related%20to%20contract%2C%20durability%20or%20off-field%20questions.%0A%0ABut%20Mathieu%20led%20the%20NFL%20in%20defensive%20snaps%20last%20season%2C%20just%20one%20removed%20from%20his%20second%20major%20knee%20injury%2C%20and%20has%20already%20proven%20he%27s%20one%20of%20the%20game%27s%20more%20perseverant%20players.%20He%27s%20also%20one%20of%20its%20most%20versatile%20and%20exciting%2C%20and%20we%20can%27t%20think%20of%20too%20many%20defenses%20that%20shouldn%27t%20want%20to%20find%20a%20place%20for%20him.%0A%0AWhile%20%22Honey%20Badger%22%20comes%20with%20a%20durability%20buyer%20beware%20tag%2C%20Ndamukong%20Suh%27s%20issues%20are%20very%20different.%20He%27s%20missed%20just%20two%20games%20in%20his%20first%20eight%20seasons%2C%20including%20a%20Defensive%20Rookie%20of%20the%20Year%20and%20five%20All-Pro%20nominations.%20He%20can%20still%20be%20a%20dominant%20player%20%E2%80%94%20when%20he%20wants%20to.%0A%0AIndeed%2C%20the%20factor%20clubs%20considering%20Suh%20must%20weigh%20%E2%80%94%20and%2C%20like%20Mathieu%2C%20there%20aren%27t%20many%20defenses%20that%20couldn%27t%20use%20Suh%27s%20services%20%E2%80%94%20is%20his%20motor%20and%20motivation.%20One%20of%20the%20NFL%27s%20best%20businessmen%20%E2%80%94%20Suh%20has%20cashed%20%24124%20million%20already%20in%20his%20NFL%20career%20%E2%80%94%20made%20no%20bones%20about%20the%20fact%20in%20a%20conversation%20with%20ESPN%20on%20Wednesday%20that%20his%20next%20team%20will%20be%20the%20one%20willing%20to%20offer%20him%20the%20most%20financially.%20Forget%20fit.%20Forget%20finally%20winning%20in%20the%20postseason%2C%20which%20Suh%20has%20yet%20to%20do%20in%20three%20games%20over%20eight%20seasons.%0A%0APerhaps%20neither%20of%20these%20players%20are%20for%20everyone%2C%20then%2C%20but%20they%27re%20both%20special%20talents%20who%20still%20will%20command%20big%20contracts%2C%20which%20is%20a%20bit%20unusual%20at%20this%20juncture%20of%20free%20agency.&body=http%3A%2F%2Felkodaily.com%2Fsports%2Ffootball%2Fthe-high-profile-cuts-speaking-of-mathieu-he-s-one%2Fimage_ce623af1-32eb-5914-89bd-4a2f98ec8534.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="em email-share-link" title="Email" data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":ce623af1-32eb-5914-89bd-4a2f98ec8534}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="fa-stack" >
                
                <i class="fa fa-envelope fa-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/football/the-high-profile-cuts-speaking-of-mathieu-he-s-one/image_ce623af1-32eb-5914-89bd-4a2f98ec8534.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":ce623af1-32eb-5914-89bd-4a2f98ec8534}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="fa-stack" >
                        
                        <i class="fa fa-print fa-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link">
        <a class="save-list-ce623af1-32eb-5914-89bd-4a2f98ec8534-btn save-asset " onclick="jQuery('.save-list-ce623af1-32eb-5914-89bd-4a2f98ec8534-form').submit(); return false;" title="Save to list" href="#"  role="button" rel="nofollow">
            <span class="fa-stack">
                
                <i class="asset-save-icon fa fa-bookmark-o fa-stack-1x"></i>
            </span>
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul>
    <form method="post" data-uuid="ce623af1-32eb-5914-89bd-4a2f98ec8534" class="save-list-ce623af1-32eb-5914-89bd-4a2f98ec8534-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="ce623af1-32eb-5914-89bd-4a2f98ec8534" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
                
                
                
                <div class="asset-comments hidden-print">
                    
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Post a comment<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="ce623af1-32eb-5914-89bd-4a2f98ec8534" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fa fa-spinner fa-spin'></span> Posting">Post comment</button>
                    </div>
                </div>

                <div class="template success" style="display:none">
                <!-- <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your comment has been submitted.</p>
    </div>

    <div class="comment-body media-body">

        <div class="avatar img-responsive"><i class="fa fa-fw fa-user"></i></div>
        <img class="avatar img-responsive" src="" alt="" />

        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
                
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
-->
                </div>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/sports/football/the-high-profile-cuts-speaking-of-mathieu-he-s-one/image_ce623af1-32eb-5914-89bd-4a2f98ec8534.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fa fa-spinner fa-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <div class="template success" style="display:none">
                <!-- <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div> -->
                </div>

                <div class="template error" style="display:none">
                <!-- <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div> -->
                </div>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch this discussion.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this discussion.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="ce623af1-32eb-5914-89bd-4a2f98ec8534" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone contributes to the discussion
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this discussion will be disabled.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div class="comments-container">
        <section id="comments" class=" p402_hide subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fa fa-comments"></span> (0) comments 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom  usernames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Welcome to the discussion.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://elkodaily.com/users/login/?referer_url=http%3A%2F%2Felkodaily.com%2Fsports%2Ffootball%2Fthe-high-profile-cuts-speaking-of-mathieu-he-s-one%2Fimage_ce623af1-32eb-5914-89bd-4a2f98ec8534.html%3Fsrc%3Drss">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules"><strong>Keep it Clean.</strong> Please avoid obscene, vulgar, lewd,
racist or sexually-oriented language.<br>
<strong>PLEASE TURN OFF YOUR CAPS LOCK.</strong><br>
<strong>Don&#39;t Threaten.</strong> Threats of harming another
person will not be tolerated.<br>
<strong>Be Truthful.</strong> Don&#39;t knowingly lie about anyone
or anything.<br>
<strong>Be Nice.</strong> No racism, sexism or any sort of -ism
that is degrading to another person.<br>
<strong>Be Proactive.</strong> Use the &#39;Report&#39; link on
each comment to let us know of abusive posts.<br>
<strong>Share with Us.</strong> We&#39;d love to hear eyewitness
accounts, the history behind an article.
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Post a comment</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch this discussion.</span>
                                    <span class="unsubscribe">Stop watching this discussion.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div>
                </div>
            </div>
            
            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                <div class="visible-lg visible-md visible-sm"><div class="tnt-ads-container text-center hidden-xs"><div style="min-height:250px; min-width:300px;" class="tnt-ads dfp-ad" data-dfp-adunit="/8438/elkodaily.com/sports/football" data-dfp-custom-pos="fixed-big-ad-top, atf, 50" id="fixed-big-ad-top" data-dfp-size="[[300,250], [300,600]]"></div></div>
    </div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"><div id="tncms-block-1466109" class="tncms-block"><section id="block-1466109" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-1466109 ">
        <div class="block-title-inner">
            <h3>
                
                Most Popular
                
            </h3>
        </div>
    </div></div>
    <div class="card">
        <ul class="list-unstyled list-popular"><li>
                    
                        <h4 class="">
        
             <a href="/opinion/editorial/editorial-north-south-freeway-will-sidestep-elko/article_3fa4d2d1-f314-5ae8-8d2d-5c01cc79f894.html">
        

        
        Editorial: North-south freeway will sidestep Elko</a></h4>
                    
                </li><li>
                    
                        <h4 class="">
        
             <a href="/news/local/crime-and-courts/wanted-sheriff-s-office-posts-mug-shots/article_2b9dd461-85d1-5521-b1e9-e6e563f198fd.html">
        

        
        Wanted: Sheriff's Office posts mug shots</a></h4>
                    
                </li><li>
                    
                        <h4 class="">
        
             <a href="/news/state-and-regional/winnemucca-pushes-for-eastern-i--route/article_fbf900d2-e958-5f68-a9de-d50d68434bb9.html">
        

        
        Winnemucca pushes for eastern I-11 route</a></h4>
                    
                </li><li>
                    
                        <h4 class="">
        
             <a href="/news/local/crime-and-courts/elko-police-called-on-apparent-heroin-overdose-death/article_8af9db72-a2b0-51c4-a2aa-dfc5babb3e08.html">
        

        
        Elko police called on apparent heroin overdose death</a></h4>
                    
                </li><li>
                    
                        <h4 class="">
        
             <a href="/news/narvaiza-running-for-sheriff/article_76ae46a5-c683-5d16-a224-f88e81ff7caf.html">
        

        
        Narvaiza running for sheriff</a></h4>
                    
                </li></ul>
    </div>
    
</section></div></div><div id="tncms-region-other_asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "></div><div class="visible-lg visible-md visible-sm"><div class="tnt-ads-container text-center hidden-xs"><div style="min-height:250px; min-width:300px;" class="tnt-ads dfp-ad" data-dfp-adunit="/8438/elkodaily.com/sports/football" data-dfp-custom-pos="fixed-big-ad-middle, stf" id="fixed-big-ad-middle" data-dfp-size="[[300,250], [300,600]]"></div></div>
    </div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"><div id="tncms-block-1516146" class="tncms-block"><section id="block-1516146" class="block emphasis-h3   " >
    
    <div class="card-img-md card-bg-color">
        
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                
                <article id="card-summary-1516146-fad75dc4-e098-11e5-8f75-27801de5054d" class="clearfix card summary has-image image-top image-left ">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-fad75dc4-e098-11e5-8f75-27801de5054d media-preview link-asset" data-aspect="16:9"><figure class="photo layout-horizontal"
            >
            <div class="image">
                
                    <a href="http://elkodaily.com/activate">
                
                
                
                
                    <img
                        src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAQAAACRI2S5AAAAEklEQVR42mM8U8+AFzCOKgADAHdUC60wg0dkAAAAAElFTkSuQmCC"
                        alt="Activate Your Digital Subscription"
                        class="img-responsive lazyload full"
                        width="300"
                        height="169"
                        data-sizes="auto"
                        data-srcset="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/assets/v3/editorial/f/ad/fad75dc4-e098-11e5-8f75-27801de5054d/56d7208a06124.preview.jpg?crop=300%2C169%2C0%2C0&resize=200%2C113&order=crop%2Cresize 200w, https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/assets/v3/editorial/f/ad/fad75dc4-e098-11e5-8f75-27801de5054d/56d7208a06124.preview.jpg?crop=300%2C169%2C0%2C0&resize=300%2C169&order=crop%2Cresize 300w" />
                </a>
            </div>
            
        </figure>
    </div>
                    </div>
                
                <div class="card-body">
                    
                        <div class="card-labels">
                            
                            
                                <div class="card-label-flags">
                                    <span class="label label-flag label-flag-default label-flag-promotion">promotion</span> 
                                </div>
                            
                        </div>
                    
                    
                    <div class="card-headline">
                        <h4 class="">
        
             <a href="http://elkodaily.com/activate">
        

        
        Activate Your Digital Subscription</a></h4>
                    </div>
                    
                    
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p>Activate now for full access to elkodaily.com and our mobile apps. </p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
            
                
                    <div class="card-panel panel">
                        <div class="panel-body">
                
                <article id="card-summary-1516146-7106748a-00b7-11e4-b55e-001a4bcf887a" class="clearfix card summary  card-section-email-updates-full-access">
            <div class="card-container">
                
                <div class="card-body">
                    
                        <div class="card-labels">
                            
                            
                                <div class="card-label-flags">
                                    <span class="label label-flag label-flag-default label-flag-promotion">promotion</span> 
                                </div>
                            
                        </div>
                    
                    
                    <div class="card-headline">
                        <h4 class="">
        
             <a href="/email-updates/full-access/thank-you-for-activating-full-access/article_7106748a-00b7-11e4-b55e-001a4bcf887a.html">
        

        
        Thank you for activating full access!</a></h4>
                    </div>
                    
                    
                    
                    
                    
                    
                        
                        
                            <div class="card-lead">
                                <p>We’re writing to thank you for your activating your full access subscription including all madison.com websites, mobile apps and more. With your “full-access” subscription to the [NEWSPAPER NAME], you get everything produced by the area’s largest news team, plus even more products and servic&hellip;</p>
                            </div>
                        
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                        </div>
                    </div>
                
            
    </div>
    
    </section></div></div><div id="tncms-region-other_asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-1466187" class="tncms-block"></div></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-other_asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"><div id="tncms-block-1466050" class="tncms-block"><div class="tnt-ads-container text-center "><div style="min-height:250px; min-width:300px;" class="tnt-ads dfp-ad" data-dfp-adunit="/8438/elkodaily.com/sports/football" data-dfp-custom-pos="fixed-big-ad-bottom, btf" id="ad-1466050" data-dfp-size="[[300,250], [300,600]]" data-lazy="true"></div></div>
    
</div><div id="tncms-block-1479951" class="tncms-block hidden-sm hidden-xs"><div class="tnt-ads-container text-center "><div style="min-height:250px; min-width:300px;" class="tnt-ads dfp-ad" data-dfp-adunit="/8438/elkodaily.com/sports/football" data-dfp-custom-pos="fixed-big-ad-bottomer, btf" id="ad-1479951" data-dfp-size="[300,250]" data-lazy="true"></div></div>
    
</div><div id="tncms-block-1466114" class="tncms-block"><div class="rail-copyright">
© 2017 Lee Enterprises | <a href="">Terms</a> | <a href="">Privacy</a>
</div></div></div></div>
                </div>
                </div>
            </div></div>
</article>


        <div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "></div></div>
        </div><div class="container-breakout"><div class="visible-lg visible-md"><div class="tnt-ads-container text-center hidden-xs"><div style="min-height:90px; min-width:728px;" class="tnt-ads dfp-ad" data-dfp-adunit="/8438/elkodaily.com/sports/football" data-dfp-custom-pos="fixed-leaderboard-bottom, btf" id="fixed-leaderboard-bottom" data-dfp-size="[[728,90], [970,90], [970,250]]" data-lazy="true"></div></div>
    </div><div class="visible-sm"><div class="tnt-ads-container text-center hidden-xs"><div style="min-height:90px; min-width:728px;" class="tnt-ads dfp-ad" data-dfp-adunit="/8438/elkodaily.com/sports/football" data-dfp-custom-pos="fixed-leaderboard-bottom, btf" id="fixed-leaderboard-bottom-tablet" data-dfp-size="[728,90]" data-lazy="true"></div></div>
    </div><div class="tnt-ads-container text-center hidden-sm hidden-md hidden-lg"><div style="min-height:50px; min-width:320px;" class="tnt-ads dfp-ad" data-dfp-adunit="/8438/elkodaily.com/sports/football" data-dfp-custom-pos="fixed-leaderboard-bottom, btf" id="fixed-leaderboard-bottom-mobile" data-dfp-size="[320,50]" data-lazy="true"></div></div>
    </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4">
        <div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-1466056" class="tncms-block site-logo-container"><div id="site-logo-1466056" class="site-logo-container text-left">
        <div class="logo-top"></div>
        <div class="logo-middle"><a  href="/"><img class="img-responsive" alt="Elko Daily Free Press" src="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/custom/image/e8f4a064-67fe-11e7-be22-5fc9e4d1e5c6.png?_dc=1499973018"></a></div>
        <div class="logo-bottom"></div>
    </div></div><div id="tncms-block-1466117" class="tncms-block site-follow-us"><div class="follow-links-1466117 default">
    
    <section id="block-1466117" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/elkodaily/" title="Facebook" target="_blank" class="btn btn-xs btn-link fb">
                    <i class="fa fa-facebook"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="https://twitter.com/elkodaily" title="Twitter" target="_blank" class="btn btn-xs btn-link tw">
                    <i class="fa fa-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
        
            <li>
                <a href="https://www.youtube.com/user/ElkoDaily" title="Youtube" target="_blank" class="btn btn-xs btn-link yt">
                    <i class="fa fa-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "http://schema.org",
  "@type" : "Organization",
  "url" : "http://elkodaily.com",
  "sameAs" : ["https://www.facebook.com/elkodaily/","https://twitter.com/elkodaily","https://www.youtube.com/user/ElkoDaily"] 
}
</script>
<div class="clearfix"></div></div></div>
        
    </div>
    <div id="footer-col-two" class="col-md-4 col-sm-4">
        <div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-1466070" class="tncms-block site-footer-heading"><section id="block-1466070" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1466070 ">
        <div class="block-title-inner">
            <h4>
                
                Sites &amp; Partners
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link"  href="/eedition/" >
                    <span class="nav-label">Print Edition Online</span>
                </a></li><li>
                <a class="nav-link"  href="/mining/" >
                    <span class="nav-label">Mining Quarterly</span>
                </a></li><li>
                <a class="nav-link"  href="/email/" >
                    <span class="nav-label">Email Alerts</span>
                </a></li><li>
                <a class="nav-link"  href="/contact/" >
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link"  href="/homes/" >
                    <span class="nav-label">Real Estate</span>
                </a></li><li>
                <a class="nav-link"  href="/online_features/" >
                    <span class="nav-label">Online Features</span>
                </a></li></ul></div>
    </div>
    <div id="footer-col-three" class="col-md-4 col-sm-4">
        <div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-1466071" class="tncms-block site-footer-heading"><section id="block-1466071" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-1466071 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-three-nav" class="tncms-region-nav"><ul id="footer-col-three-nav_menu" class="bullet-nav nav-list"><li>
                <a class="nav-link"  href="/customer-service/" >
                    <span class="nav-label">Customer Service</span>
                </a></li><li>
                <a class="nav-link"  href="/subscribenow/" >
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link"  href="/activate/" >
                    <span class="nav-label">Activate</span>
                </a></li><li>
                <a class="nav-link"  href="/place_an_ad/" >
                    <span class="nav-label">Advertise</span>
                </a></li><li>
                <a class="nav-link"  href="http://lee.net/careers/opportunities/?utm_source=newspaper&utm_medium=blox&utm_campaign=workhere"  target="_blank">
                    <span class="nav-label">Work here</span>
                </a></li></ul></div>
    </div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-1466049" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-1466049"><div class="col-md-7"><small>&copy; Copyright 2018 <a href="/">Elko Daily Free Press</a>, 3720 Idaho St Elko, NV</small><small>&nbsp;| <a href="/terms">Terms of Use</a></small><small>&nbsp;| <a href="/privacy">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="http://bloxcms.com" title="BLOX Content Management System" target="_blank">BLOX Content Management System</a> from <a href="http://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    <div id="sticky-anchor"><div id="tncms-region-page_sticky_anchor" class="tncms-region hidden-print collapse in"></div></div>
    <!-- / site-container close -->
    </div>
    
    <div class="tnt-ads-container text-center "><div style="min-height:1px; min-width:1px;" class="tnt-ads dfp-ad" data-dfp-adunit="/8438/elkodaily.com/sports/football" data-dfp-custom-pos="fixed-impact-bottom, btf" id="fixed-impact-bottom" data-dfp-size="[1,1]"></div></div>
    
    <script>
$(function(){
    var compatible = true;
    var status = "";
    if(typeof(__tnt.advertisements)=="undefined"){
        compatible = false;
        status = "FAIL: object 0 undefined"
    }
    if(typeof(__tnt.ads)=="undefined"){
        compatible = false;
        status = "FAIL: object 1 undefined"
    }
    
    if(!compatible){
        __tnt.log(status);
        
        if(window.ga){
            __tnt.trackEvent({'category':'tnt-adblock','action':'adblock','label':'adblock detected','value':'1'}); 
        
        }
    }
});
</script>

    <!-- Google Analytics:Begin -->
    <script type="text/javascript">
        (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
        ga('create', 'UA-19810821-8', 'elkodaily.com', {'allowLinker': true, 'name': 'cenTracker'});
        ga('cenTracker.set', 'dimension1', 'profootballweekly.com');
        ga('cenTracker.set', 'dimension2', 'http://www.profootballweekly.com/lists/2018/03/15/c2b9525b32694cdaa7c2a19dc670fe90/index.xml');
        ga('cenTracker.send', 'pageview');
    </script>
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }
        });
    </script>
<script>
        __tnt.trackEvent = function(obj) {
            if( jQuery.type(obj) === 'object' ){
                
                    
                        
                        if(obj.category && obj.action){
                            __tnt.googleEvent(obj);
                        } else if(obj.network && obj.socialAction){
                            __tnt.googleSocial(obj);
                        } else if(obj.url){
                            __tnt.googlePageView(obj);
                        }
                    if(typeof TNCMS.Tracking != 'undefined' && obj.metric){
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
                
            }
        }
        
        if(__tnt.trackEventLater.length > 0){
            jQuery(__tnt.trackEventLater).each(function(){
                __tnt.trackEvent($(this));
            });
        }
        jQuery('body').on(__tnt.client.clickEvent, '[data-track]', function(){
            var trkObj = jQuery(this).data('track');
            __tnt.trackEvent(trkObj);
        });
        jQuery('body').on(__tnt.client.clickEvent, '[data-tncms-track-event]', function(){
            var trkObj = jQuery(this).data('tncms-track-event');
            __tnt.trackEvent(trkObj);
        });
        jQuery('body').on(__tnt.client.clickEvent, '[data-tncms-track-dmp]', function(){
            var dmpData = jQuery(this).data('tncms-track-dmp');
            	_cc6894.add('act', dmpData);
	_cc6894.bcp();
});
    </script>
    
<script>/*<![CDATA[*/ 
        if( __tnt.user.services ){
            jQuery('body').addClass('has-service');
            jQuery('body').removeClass('no-service');
        } else {
            jQuery('body').addClass('no-service');
            jQuery('body').removeClass('has-service');
        }
     /*]]>*/</script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
        var oAmazonUrls = $("a[href*='amazon.com']");
        if( oAmazonUrls.length > 0 ){
            var sTrkId = 'tracking_id=leeenter0889-20';
            $(oAmazonUrls).each(function(i,e){
                var sHref = this.href;
                if ( !sHref.match(/[?&]tracking_id/) ) {
                    sHref += ((sHref.indexOf('?') > -1) ? '&' : '?') + sTrkId;
                    $(this).attr('href',sHref).attr('target','_blank');
                }
            });
        }
    }); /*]]>*/</script>
<script>/*<![CDATA[*/ jQuery(document).ready(function($){
        var sTrackingPattern = 'lee-track-';
        var oTrackBlocks = $('div[class*="'+sTrackingPattern+'"]');
        var sTrackVal;
        function lee_trkLinkSrc(o, src){
            var src = 'tracking-source='+src;
            $(o).find('a').each(function(){
                var sHref = this.href;
                if ( !sHref.match(/[#&]tracking-source/) && sHref != '' && sHref != '#') {
                    sHref += ((sHref.indexOf('#') > -1) ? '&' : '#') + src;
                    $(this).attr('href', sHref);
                }
            });
        }
        if( oTrackBlocks.length > 0 ){
            $(oTrackBlocks).each(function(){
                var sTrackClass = $(this)[0].classList;
                $(sTrackClass).each(function(i,c){
                    if( c.match(sTrackingPattern) ){
                        sTrackVal = c.replace(sTrackingPattern, '');
                        return false;
                    }
                });
                lee_trkLinkSrc(this, sTrackVal);
            });
        }
        lee_trkLinkSrc('#main-nav_menu', 'main-nav');
        lee_trkLinkSrc('#mobile-nav-left_menu,#mobile-nav-left-below_menu', 'menu-nav');
    }); /*]]>*/</script>
<script src="//s.skimresources.com/js/98744X1555070.skimlinks.js"></script>
<script>/*<![CDATA[*/ var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    googletag.cmd.push(function() {
        var impact_recorded=false;
        googletag.pubads().addEventListener('slotRenderEnded', function(event) {
            var slot=event.slot, ad_div_id = slot.getSlotElementId();
            if (ad_div_id.match(/^fixed-impact/) && event.creativeId && !impact_recorded) {
                __tnt.trackEvent({'category':'tnt-ads', 'action':'loaded', 'label':'high impact', 'value':1});
                impact_recorded=true;
            }
        });
    }); /*]]>*/</script>
<script>/*<![CDATA[*/ var bHasSyncCookie = jQuery.cookie('syncwall-history');
    if(bHasSyncCookie){
        jQuery.cookie('syncwall-history', null, { path: '/'});
    }
    var bHasSyncCookie = jQuery.cookie('syncwall-sessionid');
    if(bHasSyncCookie){
        jQuery.cookie('syncwall-sessionid', null, { path: '/'});
    } /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/content/tncms/live/libraries/flex/components/ads_dfp/resources/scripts/dfp.lazy.min.js?_dc=1515754648"></script>
<script>/*<![CDATA[*/ $(function() {
        var avatar_1466051 = $('#user-controls-1466051 .tn-user-avatar');
        if(__tnt.user.loggedIn && __tnt.user.avatar){
            avatar_1466051.append('<img src="' + __tnt.user.avatar + '" class="user-icon">');
        } else{
            avatar_1466051.append('<i class="fa fa-fw fa-user user-icon"></i>');
        }
    }); /*]]>*/</script>
<script>/*<![CDATA[*/ $(function() {
        var avatar_1466084 = $('#user-controls-1466084 .tn-user-avatar');
        if(__tnt.user.loggedIn && __tnt.user.avatar){
            avatar_1466084.append('<img src="' + __tnt.user.avatar + '" class="user-icon">');
        } else{
            avatar_1466084.append('<i class="fa fa-fw fa-user user-icon"></i>');
        }
    }); /*]]>*/</script>
<script src="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sticky-kit.1bb05400ffcc4ea686561f22e5585bbd.js"></script>
<script src="https://bloximages.chicago2.vip.townnews.com/elkodaily.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.regions.27c3b2f3d92ef81afb71075a652f7dca.js"></script>
<script>/*<![CDATA[*/ (function($){
                $(window).load(function(){
                    __tnt.regions.stickySide.init($('#sticky-right-rail'), $('#sticky-right-rail-spacer'), 'siderail');
                });
            })(jQuery); /*]]>*/</script>
<script>/*<![CDATA[*/ __tnt.regions.stickyAnchor.init(); /*]]>*/</script>
<script>/*<![CDATA[*/ 
        jQuery(document).ready(function($){
            var iqLogin = $.cookie('tnt-iq-login') || false;
            if (__tnt.user.loggedIn && iqLogin == false) {
                if (__tnt.user.services) {
                    var userServices = __tnt.user.services.split(',');
                    for (i = 0; i < userServices.length; i++) { 
                        var serviceData = 'has_subservice: ' + userServices[i];
                        	_cc6894.add('act', serviceData);
	_cc6894.bcp();

                    }
                }
                $.cookie('tnt-iq-login', 1);
            }
        });
     /*]]>*/</script></body>
</html>